AP Essentials - Slow Performance

Incident Report for Tungsten Automation EMEA

Resolved

The performance of the service has now returned to normal.

Sorry for any inconvenience this may have caused.
Posted Dec 01, 2025 - 16:22 UTC

Identified

We are currently experiencing performance issues with AP Essentials. We’re sorry for the disruption this is causing.

Our team has identified the cause and is actively working to resolve the issue as quickly as possible. We’ll provide an update once the service is fully restored.
Posted Dec 01, 2025 - 10:19 UTC
This incident affected: AP Essentials.