Supplier Portal – Performance Degradation

Incident Report for Tungsten Automation EMEA

Identified

We are still experiencing performance issues affecting some customers. However, our team has made progress in identifying and resolving the underlying causes. We’re continuing to work toward full resolution as quickly as possible
Posted Oct 31, 2025 - 16:01 UTC

Investigating

We’re currently experiencing performance issues affecting access to the Supplier Portal for some customers. Our team is actively working to restore normal service as quickly as possible.

We appreciate your patience and will provide an update once everything is back to normal.
Posted Oct 28, 2025 - 09:24 UTC
This incident affects: Supplier Portal.