Printix - Print Failures

Incident Report for Tungsten Automation EMEA

Postmortem

Summary 

On February 11, 2026, between approximately 20:40 and 21:38 UTC, the Printix EU cloud printing service experienced intermittent failures. During this period, some customers were unable to load printers in the Administrator portal and cloud printing was temporarily unavailable. Local printing was not affected.

 

Root Cause 

The incident was caused by a performance issue in a key service component responsible for processing internal system messages. When the system experienced a period of unusually high activity, the volume of internal messages generated exceeded the component's processing capacity, leading to increased memory churn, degraded performance and temporary service unavailability.

 

Resolution 

Our Operations team identified the issue and scaled up the affected service component. The system returned to normal operation and the incident was resolved at 21:38 UTC.

 

Preventive Measures 

A patch that addresses the underlying performance issue and reduces memory churn in the affected service component is currently being evaluated for expedited release. In parallel, configuration adjustments are being assessed to reduce the likelihood of recurrence in the interim.

Posted Feb 18, 2026 - 08:03 UTC

Resolved

This incident has been resolved.
Posted Feb 11, 2026 - 21:38 UTC

Update

We are continuing to investigate this issue.
Posted Feb 11, 2026 - 21:38 UTC

Update

Our cloud/secure print services is currently suffering intermittent failures, we are working to resolve these as quickly as possible
Posted Feb 11, 2026 - 20:50 UTC

Investigating

We are currently investigating this issue.
Posted Feb 11, 2026 - 20:40 UTC
This incident affected: Printix.