Printix Performance Degradation Issues

Incident Report for Tungsten Automation EMEA

Postmortem

Overview

On Monday 12th May, following the weekend software release, many customers experienced degraded service performance, and in some cases issues connecting to the Printix service and loading lists of available printers.  This was caused by a failure in an upgraded software library caching component, required to address regular security updates. This library was unable to cache objects above a certain size creating additional demand that affected the wider service.

 Resolution

Normal service was restored during the incident by increasing CPU resource to allow the caching software to successfully operate and deliver the required performance.  The library itself was rolled back once it was confirmed as the root cause of the incident.

 Action items

We will continue to run the original library version until the matter is addressed by the software provider and a new version is available and tested.

Posted May 15, 2025 - 14:20 UTC

Resolved

The performance issue with Printix has been resolved. We are continuing to monitor the service to ensure stability.

Thank you for your patience
Posted May 12, 2025 - 10:56 UTC

Update

We are continuing to investigate a performance issue with Printix. Our team is actively working to resolve it and will share further updates as soon as possible.
Posted May 12, 2025 - 09:21 UTC

Investigating

We are currently experiencing performance degradation of the Printix service. Investigation is currently in-progress.
Posted May 12, 2025 - 06:09 UTC
This incident affected: Printix.