AP Essentials slow processing in EU

Incident Report for Tungsten Automation EMEA

Resolved

This incident has been resolved.
Posted Jun 26, 2025 - 07:17 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 26, 2025 - 07:07 UTC

Investigating

We are currently experiencing a delay in processing for AP Essentials. Some files are taking longer than normal to be processed.

Our team is actively investigating the issue and working to restore normal processing times as quickly as possible.

We appreciate your patience and will provide an update once the issue is resolved.
Posted Jun 26, 2025 - 06:49 UTC
This incident affected: AP Essentials.