Printix - Slow Performance

Incident Report for Tungsten Automation EMEA

Resolved

We have applied a fix and seen improvements, the service is operational.
Posted Mar 25, 2026 - 16:46 UTC

Update

We are continuing to work on a fix for this issue.
Posted Mar 25, 2026 - 14:49 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 25, 2026 - 13:52 UTC

Investigating

We are aware of an issue causing slow performance for our customers. We are working to restore full service as quickly as possible.

We apologize for any inconvenience caused and appreciate your patience. Further updates will be provided as more information becomes available.
Posted Mar 25, 2026 - 11:46 UTC
This incident affected: Printix.