AP Essentials - Issues accessing application

Incident Report for Tungsten Automation EMEA

Postmortem

Overview

 

On October 29, 2025, customers experienced intermittent access issues with AP Essentials. During the incident period, the web application was temporarily unavailable.

 

Incident Detail

 

Our monitoring detected an issue affecting the application’s availability. The investigation revealed that a background process running on the application service had become stuck and was consuming system resources, preventing normal operation.

 

The engineering team promptly acted to restore service by increasing application resources and stabilizing the environment. Once the root cause was identified, the problematic process was disabled to prevent further impact.

 

Resolution

 

Access to AP Essentials was restored by scaling the application service, which immediately returned functionality for all users. The background process identified as the source of the issue was disabled pending further review. Following these corrective actions, the application has remained stable and fully accessible.

 

Next Steps / Preventive Actions

 

  • Review and optimize the background process to prevent recurrence.
  • Keep the process disabled until a stable configuration is verified.
  • Fine-tune monitoring and alerting thresholds for faster detection of similar issues.
  • Review workload scheduling to ensure background activities cannot impact core application availability
Posted Oct 29, 2025 - 15:49 UTC

Resolved

This incident has been resolved.
Posted Oct 29, 2025 - 12:26 UTC

Investigating

We’re currently experiencing issues affecting access to AP Essentials for customers. Our team is actively working to restore normal service as quickly as possible. We appreciate your patience and will provide an update once everything is back to normal
Posted Oct 29, 2025 - 12:15 UTC
This incident affected: AP Essentials.