Printix - Slow Performance

Incident Report for Tungsten Automation EMEA

Resolved

We have identified the reason for the issue, applied measures and restored normal service operation.
Posted Mar 26, 2026 - 14:23 UTC

Identified

We have identified the issue and are working on a resolution.
Posted Mar 26, 2026 - 13:46 UTC

Investigating

We are aware of an issue causing slow performance for some customers and are working to restore full service as quickly as possible.

Further updates will be provided as more information becomes available.
Posted Mar 26, 2026 - 13:07 UTC
This incident affected: Printix.