TeN Portal - Multiple features affected

Incident Report for Tungsten Automation EMEA

Resolved

Full service is now restored after changes made by our team, we apologise for the interruption to service and will investigate fully to ensure the root cause is fully understood and necessary actions taken to avoid reoccurrence.
Posted Nov 17, 2025 - 21:43 UTC

Identified

The service status remains unchanged and we continue to work to resolve this incident with our service provider. `
Posted Nov 17, 2025 - 21:11 UTC

Investigating

We are aware and currently working on a high priority issue affecting multiple features of TeN Portal, including:
Reporting
Saved invoices
Company details
Posted Nov 17, 2025 - 18:31 UTC
This incident affected: eInvoice Network.