eInvoice Connect - Slow Performance

Incident Report for Tungsten Automation EMEA

Resolved

This incident has been resolved.
Posted Feb 13, 2026 - 18:00 UTC

Update

We are progressing with the testing phase of the fix and will provide an update tomorrow.
Posted Feb 12, 2026 - 20:10 UTC

Identified

A fix for this issue is being tested and we will provide a daily update.
Posted Feb 11, 2026 - 13:44 UTC

Update

We are aware that some customers may be experiencing slow performance. We are continuing to investigate this issue.
Posted Feb 10, 2026 - 05:28 UTC

Investigating

We are aware of an issue with slow performance for eInvoice Connect. Our team is actively working on a resolution.
Posted Feb 09, 2026 - 16:55 UTC
This incident affected: eInvoice Connect.